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What’s New in Maptitude 2024 
 

Maptitude 2024: New Features Overview 

Maptitude 2024 is a major release of Caliper Corporation’s popular Geographic Information 
System (GIS) and mapping software. The 2024 version provides the most up-to-date and accurate 
data available. 

Maptitude 2024 provides the business value you expect when investing in mapping software. 
Maptitude includes the latest streets, postal data, and demographics. Maptitude 2024 is the 
fastest and most intuitive professional mapping application, with significant enhancements to 
sales territory management, sharing, visualizations, and logistics/operations analytics. 

Key Features of Maptitude 2024 
1. Provides complete support for hierarchical sales territories, such as levels for territories-

districts-regions, with any number of levels in the hierarchy, with full undo and redo, whether 
with overlapping or non-overlapping territories. 

2. The most up-to-date geographic and demographic information available, including the latest 
data and boundaries from the American Community Survey (ACS) and 2021 USA Census. 

3. Maptitude Online allows you to easily share your desktop Maptitude data privately with your 
team or publicly as a web app. Map background tiles are now provided for Belgium, Colombia, 
Denmark, Luxembourg, Malta, Mexico, Netherlands, Peru, and Spain in addition to Australia, 
Austria, Canada, France, Germany, Ireland, Italy, New Zealand, Portugal, Switzerland, UK, and 
USA. Shared maps can also be enhanced with drawing and measuring tools. 

4. Maptitude Online as a stand-alone SaaS application allows you to map your data using any 
device or operating system. New features allow you to use drawing tools to interactively 
measure features, to add shapes to maps, and to download demographics by shape as an 
Excel report, and to add new thematics for cluster/bubble and density/hot-spot visualizations. 

5. The enhancements to the Routing Deliveries & Pickups tool provide powerful new logistics 
features for optimizing your delivery fleets. You can now balance routes on “cost”, in dollars 
per mile and/or dollars per hour for breaks and/or wait times, and can specify the maximum 
weight capacities for vehicles and the weight of the goods transported. 

6. Interoperability with external data has been expanded with support for FlatGeobuf (an 
optimized vector file format), new versions of PostgreSQL, and native export to ESRI File 
Geodatabases (in addition to open and import). 

7. Support for online geospatial web services allows you to compare your routes with those 
calculated by Google, HERE, and Bing, and to geocode your locations using these services 
plus what3words. 

8. Python scripts can now be run in-process using the COM API on the Python side, and you 
can set up your preferred Python distribution and environment directly within Maptitude, e.g., 
Anaconda base. 
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Maptitude can map your information whether you have data from Google Maps, from a Microsoft 
mapping product such as MapPoint, or from Microsoft Office. You can analyze your information 
using the intuitive Maptitude 2024 mapping wizards and export your results as attractive, 
preformatted Excel or PDF reports, or upload them to Maptitude Online for public or private 
sharing.  

Maptitude delivers easy-to-use professional mapping tools and data at the unbeatable price of 
only US$695 (or US$420 for Maptitude Online.) For pricing and ordering information, please visit 
the Mapping Software Store, e-mail Maptitude Sales, or call US sales at +1 617-527-4700.  

New Data 

Maptitude 2024 comes standard with one detailed Country Package of your choice, and 
additional Country Packages can be purchased separately. Each Country Package includes a 
wealth of data unavailable in any other product, such as an up-to-date street layer with addresses 
for pin-mapping (geocoding) and travel time information for computing routes and drive-time 
rings. Features such as building footprints for many urban locations, railways, and named 
landmarks are also built into the software. The comprehensive landmarks range from public 
facilities to commercial buildings including businesses, restaurants, and retail stores, and include 
addresses and phone numbers where available. Where available, postal data and detailed 
demographics are shipped with the product. 

As you switch between the countries you have purchased, Maptitude will seamlessly refresh the 
interface with country-specific tools such as Create-A-Map Wizard and tools for finding, pin-
mapping, and routing. New Map Libraries allow you to easily create attractive geographic and 
demographic maps while locating unlimited numbers of addresses and territory-based records. 

The basic global map that is provided with every Maptitude license enables you to view your data 
for anywhere on Earth, and it allows you to map your locations by coordinate, manually, or by any 
populated place (village/town/city). 

United States 
New U.S. datasets provide access to the most up-to-date geographic information available. 
Maptitude 2024 comes with October 2023 HERE® Map Content, which allows for accurate address 
locating and street visualization, in addition to robust data that you can use to calculate 
directions, drive-time rings, and drive-time territories. Speeds based on HERE Traffic Patterns are 
included. 

Other 2023 U.S. map layers from HERE include those for buildings, highways, railroads, and 
landmarks. The Points of Interest layer contains over 3.8 million named public and business 
locations. 

Maptitude 2024 ships with the January 2024 ZIP Code update to ensure that you are using the 
latest data. The 5-digit ZIP Code boundaries are a nationwide area database with ZIP Codes for all 
50 states, the District of Columbia, Puerto Rico, and the territories.  

http://www.caliper.com/maptpric.htm
https://www2.caliper.com/store/product-category/software/
mailto:sales@caliper.com
tel:+16175274700
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Other standard features of Maptitude 2024 are updated 3-digit ZIP Code areas and a point 
database of ZIP Code points for the entire country. The ZIP Code area layers extend into non-
deliverable areas to provide complete coverage of the USA. The 3-digit and 5-digit ZIP Code 
areas include updated counts of businesses by detailed industry type (retail, finance, etc.), along 
with the number of employees working in each ZIP Code, and annual payroll figures. The ZIP 
Codes are also classified by their updated rural-urban commuting characteristics and with the 
numbers of hospitals, hospital beds, and healthcare providers. The HERE street layer indicates 
whether a street permits cars, buses, deliveries, emergency vehicles, motorcycles, pedestrians, 
taxis, through traffic, or trucks. 

The US Census boundaries (e.g., Tracts, Places, Counties, MCDs, MSAs, States) and the 3- and 5-
digit ZIP code areas that come with Maptitude contain some or all of several demographic 
profiles from a variety of data providers. These sources include the 2020 Census and the 2022 
American Community Survey (ACS) to name a few. This data is available for the USA, Puerto Rico, 
and the Territories. These layers include daytime population, and percent change (2021 to 2022) 
in population, median income, and mean income. The ZIP Code, Tract, County, and State layers 
also include updated buying power (disposable income for 2021) figures.  

Personal income and change in personal income BEA data for 2022 are included for States and 
Counties, and 2022 GDP (by total, goods, services, government, and by 2-digit NAICS code) and 
change in GDP BEA data for 2022 are included for Counties. 2025 population projections for 
Counties, States, and Tracts are included by age, race, gender, and ethnicity, and for population 
by 5-year increment for 2025-2100.  

The Demographic Map Librarian tool makes it easy to access a series of pre-defined thematic 
and shaded maps of the updated data. There are also maps for the 2020 Tract layer with updated 
banking compliance FFIEC data for 2023. 

The Country Package updates under development are listed below: 
Australia 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 
• 2021 Census Demographics 

Brazil 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

Canada 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated 3-character postal Forward Sortation Area (FSA) boundaries and centroids (HERE) 
• Updated 6-character postal point layer (HERE) 
• New 6-character postal area layer (Caliper Created/Derived from HERE) 
• 2023 Population estimates for Provinces 
• 2021 Census Demographics 

http://www.caliper.com/maptitude/international/unitedstates.htm
http://www.caliper.com/maptitude/international/unitedstates.htm
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United Kingdom 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated postal boundaries for the UK (HERE) 
• Updated postal boundaries and postcode points for GB (Caliper)  
• 2022 Estimated population by age and gender, UK 
• 2021 Census Demographics 

Mexico 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

New Zealand 
• October 2023 HERE update with speeds based on noontime HERE Traffic Patterns 
• Updated HERE postal boundaries and centroids 

Network Analysis, Directions, and Routing 

Maptitude 2024 gives you powerful tools to model routes, to calculate the distances and travel 
times between locations, and to display and analyze service provision over the road network. 

Routing & Directions Manager 
The Tools>Routing & Directions> Routing & Directions Manager now: 

• Supports custom route colors 
• A new Options>General setting in the Routing & Directions Manager allows you to compare 

your route with that calculated by web services such as Google, HERE, and Bing. 

Routing Deliveries and Pickups 
The Tools>Routing & Directions>Routing Deliveries & Pickups tool now: 

• Allows sorting by route attributes of the route list displayed in the Manager 
• Uniquely identifies each vehicle in the Manager by appending a sequential number to 

duplicate vehicle names 
• Allows time windows to span across midnight 
• Allows depots to be identified using either a string column, e.g., "name", or a numeric 

column, e.g., "ID" 
• Allows renaming of the “Schedule Title” in the Options settings 
• Allows routes to be balanced on “cost”, which is defined by the user in dollars per mile and/or 

dollars per hour for breaks and/or wait time 
• Provides improved route balancing that better respects tight constraints  
• Allows specifying of a “Weight per Unit” in the Stops tab, and the specifying of a "Max 

Weight" in the vehicle table, thus handling trucks that have maximum weight capacities 
• Provides an Edit>Preferences>Routing setting to limit how long the tool will run before 

providing a result 
• Allows routes to have transparent styles 
• Allows the Move Stop tool to move stops within a route, in addition to between routes 
• Allows an itinerary to be copied to allow exploration of what if scenarios 
• Allows depots to have zero vehicles 
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Distance and Travel-Time Tables Tool 
Maptitude 2024 makes it easy to identify alternative service suppliers, backup field 
representatives, and closest locations. The distance and drive-time tool creates an Excel table that 
lists the costs of travel between any number of origins and destinations, allowing you to easily 
sort the data to identify the closest locations. 

The Tools>Routing & Directions>Distance and Travel Time Tables tool now: 

• Can output all origin and destination attribute columns along with the calculated distances 
and travel times 

New Database Functionality 

New capabilities for geographic databases have been introduced. 

• A copy button for File>Properties>Properties>Data from allows the copying of the data 
source information or path 

• Speed improvements when operating on a large number of tables 
• A new editing tool Tools>Editing>Line Simplify/Smooth Toolbar allows for batch 

smoothing and simplifying of line features 

    

Locating Data 

The geocoding tools use the updated street and postal data, making location matching results 
more accurate than in previous versions of Maptitude. 

• A new Tools>Locate>Locate by Web Service tool allows you to geocode your locations 
using services such as Google, HERE, Bing, and what3words 

• The what3words web service is supported for geocoding using this grid-based system via 
Tools>Web Services Licenses 

• The Click Coordinate Add-In now: 
o Has a redesigned interface 
o Allows the copying of coordinates 
o Supports the what3words web service 

  

Before Smoothing After Smoothing 

https://www.caliper.com/maptitude/gisdk/clickcoordinate.htm
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Improved Create-a-Map Wizard 

Create-a-Map Wizard is now more robust and easier to use: 

• The maps have been updated with the latest geography 

 

Creating Selections and Formulas 

Condition building tools improvements: 

• The Selection>Toolbar> 
Options>Optional 
Tools>Show running total 
fields is now faster 
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Analysis Tools 

Completely new and innovative analytics have been added to Maptitude 2024: 

• The Map>New Territory Layer Wizard and the Map>Territory Manager Toolbar: 
o Allows choice of separate county and state columns when using County as the geography 

layer, and when creating territories from a table 
o Provides complete support for hierarchical territories, with any number of levels in the 

hierarchy, with full undo and redo, whether with overlapping or non-overlapping 
territories  

 

• The Tools>Analysis>Facility Location tool: 
o Automatically creates a color theme showing the color-coded assignment of clients to 

each facility 
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Output Improvements 

In Maptitude 2024: 

• Added support for longer field names in demographic overlay reports 

New Documentation 

Maptitude continues to provide numerous ways to get you started with the software. The online 
Learning Portal has been updated, and new and revised tutorials are incorporated into the 
Maptitude Help.  

In addition, a variety of comprehensive learning materials (including videos and live or pre-
recorded training webinars) are available on the Caliper Corporation website. The training videos 
run in all browsers, with playback settings, as Vimeo and YouTube videos. 

The Maptitude Help (Help>Maptitude Help) can be viewed within a web browser and has a 
modern browser-based interface. The GISDK Help (Help>GISDK Help) is available online. The 
Maptitude Online Help is available online.  

Maptitude 2024 includes a Windows Microsoft Office style question mark icon on most windows. 
Clicking this will take you to the relevant section of the Help. You can also hover over any menu 
item and click F1 to access the updated Help. In addition, several message windows in Maptitude 
link directly to the relevant Learning Portal article. 

System and Interface 

Maptitude 2024 supports the latest Windows operating systems, file types, and common design 
elements.  

• The Edit>Preferences>System>Language>Translate Interface option now supports full 
interface translation into Korean. 

• Maptitude checks on startup if the Microsoft System component WebView2 is installed and 
prompts to download it if not. 

New File Import Support 
• FlatGeobuf (*.FGB) 
• PostgreSQL newer than version 10 

New File Export Support 
• FlatGeobuf (*.FGB) 
• PostgreSQL newer than version 10 
• ESRI File Geodatabase (*.GDB)  
• GeoJson (*.GEOJSON; *.JSON) faster field name processing 

New Native File Support 
• FlatGeobuf (*.FGB) 
• PostgreSQL newer than version 10 
• Drag-drop (*.XML) files (that are not GDAL imagery) to open them in a browser control window 

https://www.caliper.com/learning/
https://www.caliper.com/learning/
https://www.caliper.com/maptitude/mapping-software-video-tutorials.htm
https://www.caliper.com/learning/gis-development-kit/#t=dk%2FIDH_CONTENTS.htm
https://www.caliper.com/maptitude-online/help/maptitude-online.htm
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Maptitude Online 

Maptitude Online is both a map sharing add-in for desktop Maptitude and a stand-alone 
mapping application.  

Online Sharing 
As a sharing add-in, maps and reports are created and uploaded using desktop Maptitude. Once 
uploaded, you can use the maps with the full functionality of the SaaS. New capabilities are listed 
below. 

• Upload up to 10 layers 
• Access the redesigned “Upload Map to Maptitude Online” window 
• Upload Map>Thematic Mapping>Pattern themes 
• Access drawing and measuring tools in shared maps 
• Upload your maps when you have a Country Package for Belgium, Colombia, Denmark, 

Luxembourg, Malta, Mexico, Netherlands, Peru, or Spain, in addition to Australia, Austria, 
Canada, France, Germany, Ireland, Italy, New Zealand, Portugal, Switzerland, UK, and USA 

 

Software-as-a-Service (SaaS) 
Desktop Maptitude is not required to use Maptitude Online. Directly from your browser you can 
upload Excel or CSV tables and map the data using the Create-a-Map-Wizard. The maps can be 
shared online publicly or privately. New capabilities are listed below. 

• Map any number of charts in a Chart Theme 
• Modify maps (hide, delete, or add layers/spreadsheets, selections, themes, styles, labels, or 

analytics) 
• Use drawing tools to measure features, to add shapes to maps, and to download 

demographics by shape as an Excel report 
• Create thematic visualizations for cluster/bubble and density/hot-spot themes 

https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#desktop
https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#app
https://www.caliper.com/maptitude/online-mapping-software-web-mapping-online-gis.htm#app


What’s New in Maptitude 2024   10 

Geographic Information System Developer’s Kit (GISDK) 

APIs 
The GISDK APIs make it easy to add mapping functionality to any Windows desktop application 
written in Python, C#, or any .NET programming language. 

Code examples and the user documentation for the Maptitude API have been updated for 
Maptitude 2024 and are included under Help>GISDK Help.  

The following functions and code have been added or modified: 

• Python scripts can be run in-process using COM API on the Python side 
• Setup your preferred Python distribution and environment, e.g., Anaconda base, via 

Tools>GISDK Developer’s Kit>Register Embedded Python… 
• caliperpy can be installed via "pip", the Python package manager 
• PowerShell 7 is installed with Maptitude, can be changed via 

Edit>Preferences…>PowerShell Engine, is used to register Python, is required to work 
through the Help>GISDK Help Python examples, and is needed to use 
File>Export>Geography…>Esri File Geodatabase 

• The Routing API creates a drawing/annotation for routes 
• The CreateObject("WebServiceGeocode") API supports online geocoding via several web 

services, including Bing, Google, HERE, and what3words  

GISDK Functions 
Please see the “Listing of GISDK Functions” topic in the Online Help to view a full list of GISDK 
functions that were added, changed, or replaced in Maptitude 2024. Highlights of the GISDK 
changes: 

• SampleArea() supports a new option for "Shape" which is "Fill" 
• SaveSampleToImage() saves a sample to an image file 
• Throw() supports a second, optional argument, for error type 

About Caliper  

Caliper Corporation develops state-of-the-art Geographic Information System (GIS) software. 
With a focus on usability, Maptitude is designed to be the most cost-effective 
professional mapping software product on the market. Maptitude enables organizations to 
leverage their location-based data to improve decision making and planning while minimizing 
expenditure through competitively priced solutions. 

Caliper is a privately held corporation and is a leading developer of mapping, 
redistricting, transportation, traffic simulation, and GIS software. 

https://www.caliper.com/learning/gis-development-kit/#t=dk%2FProgramming_Maptitude_in_Python.htm
http://www.mappingsoftware.com/
https://www.caliper.com/maptitude/gis-software/default.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/maptitude/mapping-software.htm
https://www.caliper.com/mapsoftware.htm
https://www.caliper.com/redistricting-software.htm
http://www.caliper.com/tcovu.htm
https://www.caliper.com/transmodeler/default.htm
https://www.caliper.com/maptitude/gis-software/default.htm
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