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Routing Deliveries & Pickups Add-in 

Many businesses and government agencies transport goods from one or more central locations 

to a set of destinations. It is important to manage these operations efficiently, both to reduce 

operating costs and to ensure that pickups and deliveries adhere to reasonable service 

standards. 

This general problem is known as the vehicle routing problem. Solving the vehicle routing 

problem involves determining how many vehicles are required to service the destinations, and 

developing a route and schedule for each one. Because there are many variations of the 

problem, it can be very difficult to solve. Maptitude provides a rich set of vehicle routing tools 

that solve various types of routing problems.  
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Introduction to Vehicle Routing 
The best way to introduce the vehicle routing problem is to give an example. Imagine a 

company that has one warehouse that supplies goods to 20 retail stores in various locations, as 

shown in the map below.  

Each day, trucks must deliver goods from the warehouse to each of the retail stores, and then 

return to the warehouse. Each depot has a fixed number of trucks, and each truck has a fixed 

capacity, which is a limit on the weight or volume of the goods that the truck can carry. Each 

retail store has some demand, which is the weight or volume of goods that must be delivered 

each day. In the simplest version of the vehicle routing problem, the company must determine 

the number of trucks that are needed to meet the demand at each store, and find cost-efficient 

routes for each truck.  

The starting points for each route (such as the warehouse in the above example) are known as 

depots, and the points to be visited are known as stops. A vehicle route starts at a depot, visits 

one or more stops, and may or may not return to the depot.  

The goal of the procedure is to obtain a set of routes that optimize the total time or distance 

traveled by the entire fleet of vehicles. The procedure considers the number of vehicles of 

various capacities and the cost to operate them when determining a solution. 
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There are many factors that can make a vehicle routing problem more complex. The list below 

shows some common situations that are easily handled by the Routing Deliveries & Pickups 

Add-in: 

 There is more than one warehouse location, and stores can be serviced by trucks from any

one of these warehouses. This kind of a problem is known as a multiple-depot problem.

 There are time restrictions on when deliveries can be made to some or all of the stores. For

example, a particular store might require that goods be delivered between 5:00AM and

7:00AM, before the store opens at 8:00AM. This type of restriction is known as a time

window.

 Each stop requires a certain amount of time to service. In most cases, each stop has a fixed

service time that is independent of demand. For example, it takes time to pull a truck into a

loading dock and check in with the receiver. There is also a per-unit service time that

depends upon the demand at that stop. For example, the time it takes to move boxes from

the truck onto the loading dock varies depending on how many boxes there are to move.

 There is a time restriction on total route length, or route duration. For example, when

delivering take-out food, it may be desirable that the full route length is not more than an

hour.

 There are backhaul stops. For example, vehicles may need to pick up empty containers at

the end of their delivery trip. Backhaul stops can only be visited after all delivery stops are

visited in a route.

 A vehicle route may contain mixed pickup and delivery stops, where the pickups and

deliveries do not need to correspond to each other. A stop may require either a pickup, a

delivery, or both services.

 A route does not need to end at the depot. In other words, the route does not contain the

return trip from the last stop to the depot. This is often referred as an open-ended route

instead of a closed tour. For example, a driver may want to drive home directly from the last

stop of the day instead of returning to the depot. Another example is when the route

duration constraint is effective only to the point of the last stop, such as in fresh goods

delivery services.

 There is a need to balance the routes based on either the number of stops, or the distance

traveled, or the total time traveled.

The Routing Deliveries & Pickups Add-in uses general-purpose methods that are appropriate for 

a fairly broad class of problems. There are some variations of the vehicle routing problem not 

handled directly within the Routing Deliveries & Pickups Add-in. Here are a few examples: 

 Mixed products – Several different products must be delivered in the same vehicle, but some

vehicles have restrictions on the goods that can be carried

 Partially pre-ordered routes – Certain stops must be visited in an exact order

 Other constraints – There are work rules or regulations that impose other types of constraints

on the routes to be developed

Custom solutions for many of these variations on the vehicle routing problem are available from 

Caliper Corporation. In addition, the general-purpose methods that are included with Maptitude 

can be modified to handle special restrictions or to improve performance for some types of 

problems. Please contact Caliper Corporation for more information. 
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Preparing Data for Vehicle Routing 
The Routing Deliveries and Pickups add-in requires the following: 

 A point layer with the location of depots (the “depot layer”) that includes the times that

vehicles can be dispatched.

 A point layer with the location of stops (the “stop layer”) that includes the times that the

stops can be serviced, the unit demand, and both service and per-unit times

 Information on the availability of vehicles, their capacity, and their cost at each depot. This

can be in a table (the “vehicle table”) or entered and saved when using the Routing Deliveries

and Pickups add-in.

Depot and Stop Layers 
To solve a vehicle routing problem, you must first prepare layers that contain the point locations 

of the depots and stops. The depots and stops can be either in the same layer, or in different 

layers.  

If you use a single layer for both depots and stops, or if your layers contain extra points other 

than stops and depots, you must create a depot selection set and a stop selection set. You can 

create selection sets of stops and depots using any of the Maptitude selection commands and 

tools. For more information on selection sets, see Queries and Selection Sets, in the Maptitude 

Help. 

If you already have a point layer or layers for the depots and stops but some of the required 

fields are missing, you can add them using the Dataview>Table>Modify command, or create a 

joined view using the Dataview>Table>Join command. For more information, see Working 

with Tables, Databases, & Charts, in the Maptitude Help. 

Depot Layer Fields 

The depot layer must contain certain fields that are used in vehicle routing: 

Field Type Contents 
ID integer A number that uniquely identifies the depot 

Name string A name that is used to identify a depot in the route reports 

Open Time integer The earliest time, in military format (e.g. 1700 for 5:00pm), that vehicles can be 

dispatched from the depot 

Close Time integer The latest time, in military format, that vehicles can return to the depot 

The fields do not need to have the exact names indicated above, although using these names 

may make it easier for you to use the routing procedures. 

The Open Time and Close Time fields define the time window from which vehicles may be 

dispatched. For more information on time window inputs, see “Time Windows” below. 
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Stop Layer Fields 

The stop layer must have the following fields: 

Field Type Contents 
Name string A name that is used to identify a stop in the route reports 

Open Time integer The earliest time, in military format (e.g. 1700 for 5:00pm), that vehicles can be 

serviced; See “Time Windows” below for more information; See “Time Windows” below 

for more information 

Close Time integer The latest time, in military format, that a stop can be serviced; See “Time Windows” 

below for more information 

Service Time numeric The minimum time required to service a stop (in minutes); See “Service Times” below 

for more information 

Per Unit Time numeric The service time required for each unit of demand (in minutes); See “Service Times” 

below for more information 

Delivery Demand numeric The delivery demand at a stop (not required for Pickup mode) defined as units, volume, 

or weight and must match the units used to define the capacity of vehicles 

Pickup Demand numeric The pickup demand at a stop (not required for Delivery mode) defined as units, volume, or 

weight and must match the units used to define the capacity of vehicles 

If you are routing from multiple depots, you have the option to pre-assign any number of stops 

to depots. To pre-assign stops to depots, the stop layer must include a field containing the ID 

numbers of the depots to which each stop is assigned: 

Field Type Contents 
Depot Assigned integer The ID of the specific depot which services a stop. Maptitude will use the assigned depot 

when present and will choose the nearest depot when this value is blank. If a depot has 

excessive demand over its total vehicle capacity, some stops may be assigned to the 

second nearest depot. 

The Routing Deliveries and Pickups add-in will also let you specify additional fields that you may 

want included in the vehicle reports (e.g., address, contact name, drop-off instructions). 

Time Windows 
In both the depot and the stop layers, the Open Time and Close Time fields use military format, 

so 8:30AM should be written as 830, while 6:30PM should be written as 1830. Times beyond 

midnight are written as numbers over 2400; for example, 12:30AM should be written as 2430. 

Here are some examples: 

Open Time Close Time Comments 
500 830 Stop must be made in the early morning 

1200 1245 A very small time window for making the stop 

700 1900 There is essentially no restriction on servicing this stop 

2200 2500 Stop must be made between 10:00PM and 1:00AM 

1200 1100 This time window is invalid, and would cause an error 

In general, as the time windows become more and more restrictive, the number of vehicles that 

are required to service the stops increases. If you do not need time window restrictions, you can 

simply set the open time to 0 and the close time to a large number (e.g., >2400). 

A stop can also have multiple time windows. For example, a stop may accept deliveries from 

10:00AM to noon and again from 2PM to 5PM. In this case, you will need separate fields in the 

stop layer for each of the time windows (e.g., OpenTime1, CloseTime1, OpenTime2, CloseTime2). 
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Service Times 
The Routing Deliveries & Pickups Add-in accounts for the time required to service each stop 

when calculating routes. The service time can have a fixed component and a variable component 

that is demand dependent (time per unit). Both of these components can vary from stop to stop. 

The fixed time, for example, at one stop may take longer if it is difficult to park there or if it lacks 

a loading dock. Likewise, the per-unit time may be longer at a stop that requires delivery to an 

upper floor.  

The amount of time it takes to service a stop is as follows: 
service time = (fixed time) + (number of units) * (time per unit) 

Vehicle Data 
Vehicle information can be entered manually while performing vehicle routing or imported from 

a vehicle table. For each depot, you must specify the types of vehicles available. For each vehicle 

type, you must specify: 

 A unique ID for the vehicle, such as VIN, license plate, etc.

 The capacity of the vehicle, which must match in units the demand at the stops

 The purchase/operating/rental cost

If you are importing the vehicle information from a table, it must contain the following fields: 

Field Type Contents 

Depot ID Integer The ID corresponding to the depot ID in the depot layer 

Vehicle ID String The ID corresponding to the vehicle 

Type String Descriptive text describing the vehicle 

Capacity Real The capacity of the vehicle, which must match in units the demand at the stops 

Cost Real The purchase/operating/rental cost of each vehicle type 

Solving the Vehicle Routing Problem 
The Routing Deliveries and Pickups add-in solves complex routing problems with time window, 

heterogeneous fleet, backhaul, mixed pickup and delivery, and route length constraints. It can 

handle multiple depots and open-ended routing problems. Additionally, you can choose to 

balance routes based on any of three different criteria: time, distance, or the number of stops. 

In addition, if some stops are not visited due to any restriction (such as vehicle capacity or time 

windows), a selection set named “Unserviced” will be created on the stop layer.  

� To Solve the Vehicle Routing Problem

1. Open a workspace with a map that contains a depot layer and a stop layer.

2. Choose Tools>GIS Developer’s Kit>Add-Ins>Routing Deliveries & Pickups to start the

Routing Deliveries & Pickups Wizard.

3. Choose the Create New Vehicle Routes option from the radio list.

4. From the Operation Mode drop-down list, make choices as follows:

NOTE: 

Capacity can be 

defined as a number 

of units, volume, or 

weight, but must 

match the units used 

to define demand in 

the stop layer. See 

page 4 for more 

information on stop 

layers. 

NOTE: 

Certain combinations 

of time windows and 

service times may 

make it infeasible to 

service some stops. 
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Option When to use it… 
Delivery Vehicles from the depots will only be delivering units to the stops 

Pickup Vehicles from the depots will only be picking up units from the stops 

Mixed Pickup & Delivery Vehicles from the depots may be picking up or delivering units 

Backhaul Vehicles need to pick up empty containers at the end of their delivery trip 

5. If your stop layer contains records with multiple time windows, specify the maximum

number of time windows.

6. Click Next> to specify information about the stops. Make choices as follows:

7. Click Next> to specify information about the depots. Make choices as follows:

8. Click Next> to specify information about the vehicles.

9. To manually specify the available vehicles, click  to add a vehicle type. 

If you have a vehicle table, click , choose a file type, browse for the table, and click Open 

to display the Load Vehicle Table dialog box. Verify that the correct fields are chosen for

Depot ID, Type, Cost, Number of Vehicles, and Capacity, and click OK.

Choose the depot layer 

Choose whether to use all 
depots or a selection set 

Specify the fields in the depot 
layer containing the depot ID, 
name, open time, and close time 

Choose the layer 

Choose whether to use all 
features or a selection set 

Specify the fields in the layer 
containing the name, demand, 
fixed service time, per unit 
service time, open time, and 
close time; optionally, if some 
stops are serviced by a particular 
depot, specify the field that 
contains the assigned depot 

Click to choose any field that 
contains data to be included in 
reports 
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10. For each vehicle type that you add, make choices as follows:

- Choose the depot to which the vehicle belongs from the drop-down list in the Depot 

column 

- Enter the ID, license plate tag, or other vehicle identifier in the Vehicle ID column 

- Enter the type of vehicle in the Type column 

- Enter the purchase/operating/rental cost in the Cost column 

- Enter the capacity of the vehicle, using the same units as stop layer demand, in the 

Capacity column 

Repeat steps 9 and 10 until you have defined all of the vehicles available at each depot. 

11. Click Next> to specify additional options for the procedure. Make choices as follows:

12. Click Finish.

13. Browse for a folder in which to save the results and click Select Folder.

Enter a description 

Choose whether vehicles should return 
to the depot 

Specify shuffling space and departure 
load for mixed routes 
Enter the maximum route duration 

Choose how to balance routes 
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Maptitude solves the vehicle routing procedure, displays the routes on the map, and opens the 

Routing Deliveries & Pickups Manager. 

� To View Details About One or More Routes

1. You can view details about routes, display a map of a single route, and create reports with

detailed information about the routes using tools in the Routing Deliveries & Pickups

Manager as follows:

To do this... Do this... 
See the list of stops for a route Click  next to the route to see the arrival and departure time at the stop and 

the pickup and demand load 

Display a single route on the map Double click a route in the list, right-click on a route in the list and choose 

Display Route [Route Name], or highlight a route in the list and click 
Display all routes on the map Right-click on the description at the top of the list and choose Display 

Route, or highlight the description at the top of the list and click  
Generate an itinerary report for a route Right-click on a route in the list and choose Create Report for [Route 

Name], or highlight a route and click 
Generate an itinerary report for all routes Right-click on the description at the top of the list and choose Create 

Report, or highlight the description at the top of the list and click  

� To Load Existing Routes onto a Map 

1. Open a map that contains a depot layer and a stop layer.

2. Choose Tools>GIS Developer’s Kit>Add-Ins >Routing Deliveries & Pickups to start the

Routing Deliveries & Pickups Wizard.

3. Choose the Load Existing Vehicle Routes option from the radio list.

4. Browse for the Vehicle Routing Configuration file (.VRPConfig) and click Open.

5. Click Next to display the Customers page.

6. The customer layer and fields are loaded from the previous run of the procedure. Make any

changes and click Next to display the Depots page.

7. The depot layer and fields are loaded from the previous run of the procedure. Make any

changes and click Next to display the Vehicles page.

8. The vehicles used from the previous run of the procedure are displayed. Make any changes

to the vehicles and click Next.

9. The options used from the previous run of the procedure are displayed. Make any changes

to the options and click Finish.
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Maptitude solves the vehicle routing procedure, displays the routes on the map, and opens the 

Routing Deliveries & Pickups Manager. 

Try it Yourself ... A 60-Second Tutorial: Solving a Vehicle Routing Problem 

1. Choose File>New Workspace, chose New

map of my data/table/spreadsheet from

the frist scroll list, and cilck OK.

2. In the Tutorial folder, open the Excel

spreadsheet with logistics data for your

country (e.g., Logistics Australia.xlsx, Logistics

United States.xlsx, etc.).

3. Choose the Depots sheet and click OK.

Maptitude displays Create-a-Map Wizard.

4. Click Next>, choose the first “Locate” option

in the scroll list, and click Finish. Maptitude

locates the two depots. Click OK to close the

Results dialog box.

5. In the Display Manager, click the style sample

next to the Depots Layer to display the Style

dialog box. Change the size to 16pt, change

the color, change the icon to a solid square,

and click OK.

6. Choose Map>Add Table/Spreadsheet to a

Map and choose the same logistics Excel file

in the Tutorial folder.

7. Choose the Clients sheet and click OK.

Maptitude displays Create-a-Map Wizard.

8. Click Next>, choose the first “Locate” option

in the scroll list, and click Finish. Maptitude

locates the clients. Click OK to close the

Results dialog box.

9. Choose Tools>GIS Developer’s Kit>Add-Ins

>Routing Deliveries & Pickups to display

the Routing Deliveries & Pickups Wizard.

10. Click the Create New Vehicle Routes radio

button, verify that Delivery is chosen from

the Operation Mode drop-down list, and click

Next> to display the Customers page.

11. Notice that the Routing Deliveries & Pickups

Add-in already has chosen to use all features

in the Clients layer and has found the fields

for name, service time, and time window.

Choose [Number of Units] for the Delivery

Demand and click Next> to display the

Depots page.

12. Notice that the Routing Deliveries & Pickups

Add-in already has chosen to use all features

in the Depots layer and has found the fields for

name, open time, and close time. Click Next>

to display the Vehicles page.

13. Click four times to add 4 vehicles. 

14. Click and drag to highlight all of the cells in the

Cost column and type 100 to set the costs for

all four vehicles.

15. Click and drag to highlight all of the cells in the

Capacity column and type 250 to set the

capacities for all four vehicles.

16. Choose Depot 1 from the drop-down list in

the Depot column for two of the vehicles, and

Depot 2 for the other two vehicles.

17. Click Next> to display the Options page.

18. Enter 8 in the Maximum Route Duration box,

choose Time (in hours) from the Balance

Routes By drop-down list, and click Finish.

Maptitude displays the Save Vehicle Routing

Results In dialog box.

19. Right-click in the dialog box, choose New>

Folder, name the folder My VRP Results, and

click Select Folder.

20. Click  next to a route to see the stops that 

route services.

21. Right-click the itinerary description at the top

of the list and choose Create Report.

Maptitude creates a PDF report. Scroll through

the PDF to see the itinerary for each route.

Close the report when you are done.

22. Choose File>Close Workspace and click

Don’t Save to close the workspace without

saving changes to the map.
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Editing Vehicle Routes 
Once you have created vehicle routes, you can use the Routing Deliveries & Pickups Manager to 

modify routes.  

Sometimes there will be stops that were not assigned to any route in the initial solution, or that 

are removed from routes by you. These stops are referred to as unserviced customers. The 

Routing Deliveries & Pickups Manager lets you handle unserviced customers in several ways: 

 You can modify the settings that were used to produce the routes and rerun the procedure.

For example, you could modify the number of trucks available or change the balancing

method, then rerun the procedure to see if there are fewer unserviced customers.

 You can use the tools to manually move stops from one route to another, add unserviced

customers to a route, or remove stops from a route. Changes you make to the routes are

automatically updated on the map and in the Routing Deliveries & Pickups Manager.

� To Modify the Customers Serviced 

1. Click  to display the Customers portion of the Routing Deliveries & Pickups Wizard. 

2. Make any changes to the customers, such as the layer and/or selection set to use, and click

OK.

3. Click  to run the vehicle routing procedure again with the changes to the customers. 

� To Modify the Depots Serviced

1. Click  to display the Depots portion of the Routing Deliveries & Pickups Wizard. 

2. Make any changes to the depots, such as the layer and/or selection set to use, and click OK.

3. Click  to run the vehicle routing procedure again with the changes to the depots. 

� To Modify the Available Vehicles 

1. Click  to display the Vehicles portion of the Routing Deliveries & Pickups Wizard. 

2. Make any changes to the vehicles available at each depot and click OK.

3. Click  to run the vehicle routing procedure again with the changes to the vehicles. 

� To Modify the Route Duration, Route Balancing, and Other Settings 

1. Click  to display the Options portion of the Routing Deliveries & Pickups Wizard. 

2. Make any changes to the options and click OK.

3. Click  to run the vehicle routing procedure again with the changes to the options. 

� To Move a Stop to a Different Route

1. Click  in the Routing Deliveries & Pickups Manager to activate the Move a Stop tool. 

2. Click on a stop, then click on the route to which you wish to add the stop. Where you click

on the route will determine the sequence in which the stops are serviced. Stops earlier in the

route will be unchanged; stops later in the route will be serviced after the inserted stop. You

will be warned if moving a stop violates time window or vehicle capacity constraints.

3. If you click a location where there is more than one route, Maptitude displays the Pick

Destination Route dialog box. Choose the route you wish to move the stop to and click OK.
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4. The stop is removed from the sequence of stops in the initial route, and inserted into the

new route. Maptitude recalculates the changed routes, highlights them on the map, and

shows detailed information about the change in the Routing Deliveries & Pickups Manager.

5. Click  to save the changes or click  to cancel the changes. 

If you save the changes, Maptitude updates the changed routes and redraws the map. 

� To Add an Unserviced Customer to a Route

1. Click  in the Routing Deliveries & Pickups Manager to activate the Add an unserviced 

customer to a route tool.

2. Click on an unserviced customer, then click on the route at the location where you would

like to move the stop. Where you click on the route will determine the sequence in which

the stops are serviced. Stops earlier in the route will be unchanged; stops later in the route

will be serviced after the inserted stop. You will be warned if moving a stop violates time

window or vehicle capacity constraints.

3. If you click a location where there is more than one route, Maptitude displays the Pick

Destination Route dialog box. Choose the route you wish to add the unserviced customer to

and click OK.

4. Maptitude recalculates the route with the new stop, highlights the new route on the map,

and shows detailed information about the new route sequence in the Vehicle Route Editing

toolbox. Any stops that violate time window constraints are shown in red in the scroll list.

5. Click  to save the changes or click  to cancel the changes. 

If you save the changes, Maptitude inserts the unserviced customer into the route, and redraws 

the map with the new route. 

� To Remove a Stop from a Route

1. Click  in the Routing Deliveries & Pickups Manager to activate the Remove a Stop tool. 

2. Click on the stop you wish to remove from a route.

3. Maptitude recalculates the route without the stop, highlights the new route on the map, and

shows detailed information about the new route sequence in the Vehicle Route Editing

toolbox. Any stops that violate time window constraints are shown in red in the scroll list.

4. Click  to save the changes or click  to cancel the changes. 

If you save the changes, Maptitude removes the stop from the route and adds it to the 

unserviced selection set. 

� To Delete a Route

1. Click  in the Routing Deliveries & Pickups Manager to activate the Delete a Route tool. 

2. Click on the route you wish to remove.

3. If you click a location where there is more than one route, Maptitude displays the Pick

Destination Route dialog box. Choose the route you wish to delete and click OK.

4. Maptitude highlights the route on the map.

5. Click  to save the changes or click  to cancel the changes. 

If you save the changes, Maptitude deletes the route, makes all of the stops along the route 

unserviced, and adds them to the unserviced selection set. 


